Приветствие

Программа Garmin POI Loader позволяет получать пользовательские объекты (POI) из файлов данных (.csv и .gpx) и устанавливать их на устройство Garmin или на карту памяти.

Пользовательские объекты помещаются на карту и дополняют существующие данные на карте. Такими объектами могут быть новые рестораны, места отдыха, торговые центры и любые другие места.

Пользовательские объекты также могут обозначать знаки остановки или зоны с ограничением скорости и содержать информацию для оповещения о скорости и сближении. Такие объекты можно загрузить на устройство GPS и получать оповещения о сближении при приближении к пользовательскому объекту или оповещения о скорости при слишком быстром движении. Дополнительную информацию см. в разделе Пороги оповещения о скорости и о сближении.

Пользовательские объекты могут содержать аудиофайлы и настраиваемые изображения .bmp.

Можно создать собственные файлы пользовательских объектов или загрузить их из других источников, в том числе из Интернета. Можно также удалить существующие пользовательские объекты с устройства.

Кроме того, можно создавать файлы TourGuide, содержащие аудиофайлы .mp3 с информацией об объектах. Аудиофайлы будут воспроизводиться на совместимом устройстве Garmin в точках TourGuide. ПРИМЕЧАНИЕ. Файлы TourGuide обычно создаются сторонними разработчиками.

В программе POI Loader доступно два режима, позволяющих загрузить пользовательские объекты на устройство: Быстрый режим (рекомендуется) и Ручной режим (для опытных пользователей).

Если при установке POI Loader возникли проблемы или возникают вопросы о программе POI Loader, посетите страницу с ответами на часто задаваемые вопросы о POI Loader на веб-сайте Garmin (www.garmin.com).

Дополнительную информацию см. в следующих разделах:

Быстрый режим

Ручной режим

Пороги оповещения о скорости и о сближении

Создание файлов пользовательских объектов


Быстрый режим

Быстрый режим идеально подходит для загрузки пользовательских объектов, не содержащих информации о скорости (например, рестораны, плавательные бассейны или банкоматы), а также пользовательских объектов, содержащих информацию о скорости, которую не требуется изменять.

Если в файлах данных содержатся пороги оповещения о скорости и о сближении, POI Loader может автоматически определить их по ключевой информации. POI Loader проверяет имя файла на наличие доступной информации о скорости и ключевых слов для определения порога оповещения (например, "redlight", "camera" или "safety"). Если порог для оповещения о скорости отсутствует в файле данных или является неполным, POI Loader использует файл в качестве обычного файла объекта. Дополнительную информацию см. в разделах Пороги оповещения о скорости и о сближении и Создание файлов пользовательских объектов.

Если требуется указать пороги оповещения о скорости и о сближении вместо данных, находящихся в имени файла, используйте ручной режим для ввода дополнительной информации.

Чтобы загрузить объект с использованием быстрого режима:

  1. Включите устройство GPS Garmin и подключите его к компьютеру. При использовании устройства чтения карт памяти подключите его к ПК.

  2. Запустите POI Loader и щелкните Далее.

  3. Убедитесь, что в поле Устройства отображается соответствующее устройство. В противном случае щелкните Найти устройство. Если к компьютеру подключено несколько устройств, выберите необходимое устройство из раскрывающегося списка.

  4. Щелкните Далее.

  5. Выберите папку, в которой находятся файлы данных. POI Loader обнаружит все файлы данных .csv и .gpx в папке. Если файлы данных сохранены во вложенных папках, при загрузке на устройство программа POI Loader создаст подкатегории для таких файлов пользовательских объектов. Например, если основная папка содержит дополнительные папки "Food", "Resorts" и "Stores", программа POI Loader создаст на устройстве подкатегории Food, Resorts и Stores.

  6. Выберите подходящие единицы расстояния и скорости (футы и миль/ч или метры и км/ч).

ПРИМЕЧАНИЕ. POI Loader использует эти единицы для интерпретации данных в файлах данных. При выборе единиц, которые не совпадают с единицами файла данных, оповещения о скорости будут неправильными.

  7. Выберите Быстрая и щелкните Далее. POI Loader установит пользовательские объекты на устройство.

ПРИМЕЧАНИЕ. Эта операция приведет к замене всех существующих пользовательских объектов, установленных на устройстве.

  8. Щелкните Готово.


Ручной режим

Если требуется указать информацию о скорости для пользовательских объектов, используйте ручной режим. Ручной режим позволяет указать необходимые пороги оповещения о скорости и сближении для каждого загружаемого файла данных. В ручном режиме можно изменить информацию о скорости и сближении, указанную в именах загружаемых файлов данных. Например, если выполняется загрузка файла "Speed_30", но требуется по умолчанию использовать скорость 25, в ручном режиме можно ввести скорость 25. Дополнительные сведения см. в разделе Пороги оповещения о скорости и о сближении.

Если в файлах данных не требуется изменять пороги оповещения о скорости и о сближении, используйте Быстрый режим.

Чтобы загрузить объекты с использованием ручного режима:

  1. Включите устройство GPS Garmin и подключите его к компьютеру. Если используется устройство для считывания карт памяти, подключите его к компьютеру.

  2. Запустите POI Loader и щелкните Далее.

  3. Убедитесь, что устройство отображается в поле Устройство. В противном случае щелкните Найти устройство. Если к компьютеру подключено несколько устройств, выберите необходимое устройство в раскрывающемся списке.

  4. Щелкните Далее.

  5. Выберите "Установить новые настраиваемые объекты на устройство".

  6. Выберите папку, в которой находятся файлы данных. POI Loader обнаружит все файлы данных .csv и .gpx в папке. Если файлы данных сохранены во вложенных папках, при загрузке на устройство программа POI Loader создаст подкатегории для таких файлов пользовательских объектов. Например, если основная папка содержит дополнительные папки "Food", "Resorts" и "Stores", программа POI Loader создаст на устройстве подкатегории Food, Resorts и Stores.

  7. Выберите подходящие единицы расстояния и скорости (футы и миль/ч или метры и км/ч).

ПРИМЕЧАНИЕ. POI Loader использует эти единицы для интерпретации данных в файлах данных. При выборе единиц, которые не совпадают с единицами файла данных, оповещения о скорости будут неправильными.

  8. Выберите Вручную и щелкните Далее.

  9. Настройте параметры для каждого файла данных:

  10. Если требуется игнорировать определенные файлы, установите флажок "Игнорировать этот файл?".

  11. Если файл содержит точки оповещения о сближении, установите соответствующий флажок.

  12. Выберите параметры оповещения.

    • Для установки оповещения о скорости щелкните Оповещение при превышении порога скорости и введите скорость, при которой будет подан сигнал.

    • Для установки оповещения о сближении щелкните Оповещение при приближении к месту и введите необходимое расстояние.

  10. Щелкните Далее.

  11. Повторите п. 8–9 для каждого файла данных, который требуется загрузить. После выбора параметров оповещения для всех файлов данных программа POI Loader установит объекты на устройство.

ПРИМЕЧАНИЕ. Эта операция приведет к замене всех существующих пользовательских объектов, установленных на устройстве.

  12. Щелкните Готово.


Пороги оповещения о скорости и о сближении

POI Loader автоматически проверяет файлы данных .csv и .gpx на наличие порогов оповещения о скорости и о сближении

Можно также использовать ручной режим, чтобы указать необходимые пороги оповещения о скорости и о сближении.

Данные о скорости

Данные о скорости могут быть записаны в имени файла или в имени отдельного объекта в файле.

POI Loader определяет пороги скорости на основании следующей информации, упорядоченной по уменьшению приоритета.

  1. Информация о скорости, указанная в имени отдельного пользовательского объекта. Например, для объекта с именем "SpeedZone@30" порог оповещения о скорости будет равен 30 независимо от информации о скорости, указанной в ручном режиме или в имени файла.

  2. Информация о скорости, введенная в ручном режиме.

  3. Информация о скорости, указанная в имени файла. POI Loader интерпретирует все цифры в имени файла как информацию о скорости.

Порог оповещения о сближении

Порог оповещения о сближении может быть рассчитан автоматически на основе информации о скорости. Он может быть указан в файлах данных .gpx или добавлен в ручном режиме.

POI Loader определяет пороги оповещения о сближении на основании следующей информации, упорядоченной по уменьшению приоритета.

  1. Порог оповещения о сближении для отдельного объекта, указанный в файле .gpx. Эти данные имеют больший приоритет, чем другие пороги оповещения о сближении.

  2. Порог оповещения о сближении, введенный в ручном режиме.

  3. Расстояние для оповещения о сближении рассчитывается POI Loader на основании данных о скорости в имени файла или в имени отдельного объекта. Вычисление производится по следующей формуле.

Расстояние = 36 секунд * скорость.

  4. Порог оповещения о сближении по умолчанию – 400 метров/0,25 мили, если в имени файла содержится слово "redlight".

  5. Если присоединен аудиофайл TourGuide и нет других данных для оповещения о сближении, POI Loader устанавливает расстояние 0,25 мили.

Дополнительные сведения см. в разделе Создание файлов пользовательских объектов


Создание файлов пользовательских объектов

Опытные пользователи могут создать собственные файлы данных .csv и .gpx, содержащие списки пользовательских объектов, или файлы TourGuide.

Программа POI Loader загружает все файлы данных .csv и .gpx, сохраненные в определенной папке. При создании или загрузке файлов данных пользовательских объектов рекомендуется сохранять все файлы данных для загрузки на устройство в одну папку.

POI Loader определяет, содержит ли файл пороги оповещения о скорости и о сближении, на основании некоторых критериев. При создании файлов пользовательских объектов используйте следующую информацию.

  • Если в имени файла содержится допустимое значение скорости или имена всех записей в файле содержат допустимое значение скорости, все записи файла будут содержать порог оповещения о скорости и о сближении. Например, файл данных с именем "Speed_30" создает оповещения о скорости со значением 30 миль/час (или км/ч в зависимости от единиц, выбранных в POI Loader) для каждого объекта файла.

  • Если в имени файла содержится сочетание "redlight", POI Loader считает, что все записи в файле должны создавать оповещение о сближении на расстоянии 400 м/0,25 мили от объекта.

  • Если файл содержит слова "GATSO", "mobile", "SPECS", "safety", "speed" или "camera", но не содержит значения скорости, POI Loader использует порог скорости по умолчанию 0. Оповещение будет производиться в любом случае. Это значение можно изменить, введя скорость в ручном режиме.

  • Можно также ввести значение скорости для каждого объекта по отдельности. Для этого введите символ @ и число после имени объекта. Например, пользовательский объект с именем "Ridgeview@25" создаст объект с именем "Ridgeview" с оповещением при скорости 25 миль/час.

  • POI Loader рассчитывает расстояние для оповещения о сближении на основе скорости. Можно ввести расстояние с целью оповещения о сближении для отдельного пользовательского объекта в файле .gpx. Можно также ввести расстояние для оповещения о сближении для всех пользовательских объектов в файле данных, используя ручной режим.

Дополнительные сведения см. в разделе Пороги оповещения о скорости и о сближении.

Дополнительную информацию см. в следующих разделах.

Создание пользовательских объектов в MapSource

Создание файлов .CSV

Загрузка настраиваемых растровых изображений


Создание пользовательских объектов в MapSource

Пользователи могут создавать пользовательские объекты и сохранять их в файлах .gpx.

К пользовательским объектам можно присоединить аудиофайлы .mp3. Можно также создать точки TourGuide, содержащие файлы .mp3 с аудиоинформацией об объекте. При приближении к такому объекту на устройстве Garmin вместо стандартного сигнала оповещения воспроизводится аудиофайл .mp3.

Чтобы создать файл .gpx с помощью MapSource:

  1. Запустите программу MapSource.

  2. Создайте маршрутную точку. Для этого используйте инструмент маршрутной точки, функцию Найти или щелкните правой кнопкой мыши по карте. Появится диалоговое окно свойств маршрутной точки.

  3. Введите данные в соответствующие поля. ПРИМЕЧАНИЕ. Значения порогов оповещения о скорости и сближении, введенные в эти поля, имеют больший приоритет, чем информация в имени файла или введенная в ручном режиме. Дополнительные сведения см. в разделах Пороги оповещения о скорости и о сближении и Создание файлов пользовательских объектов.

Имя — введите имя объекта, содержащее пороги скорости. ПРИМЕЧАНИЕ. Введенные таким способом данные имеют больший приоритет, чем информация в имени файла или введенная в ручном режиме.

Сближение — снимите флажок с поля Неизвестно рядом с полем Сближение и введите соответствующее расстояние. ПРИМЕЧАНИЕ. Информация оповещения о сближении, указанная здесь, имеет больший приоритет, чем информация, введенная в имени файла или в ручном режиме.

Комментарий — введите комментарий.

Файл/URL — введите имя файла или выберите файл .mp3, который будет присоединен к пользовательскому объекту. Можно присоединить аудиофайлы .mp3 и файлы изображений .jpeg или .bmp. Также можно указать имя папки, в которой будут находиться все эти файлы. Например, если указать путь "C:\MyPOIs\Data", то все находящиеся в этой папке файлы .mp3, .jpeg и .bmp будут присоединены к пользовательским объектам. Можно также указать относительный путь к этой папке, если он существует.

  4. Щелкните OK.

  5. При необходимости повторите шаги 2-4.

  6. Выберите Файл > Сохранить как и выберите соответствующую папку. ПРИМЕЧАНИЕ. Рекомендуется сохранять все данные пользовательских объектов в одной папке.

  7. Введите имя файла. Для установки скорости по умолчанию для объектов в файле добавьте значение порога оповещения о скорости в имя файла (например, "Speed Zones 25"). POI Loader интерпретирует все числа в имени файла как информацию о скорости. Дополнительные сведения см. в разделе Создание файлов пользовательских объектов.

  8. Выберите Формат GPS eXchange (*.gpx) в раскрывающемся списке Тип файла.

  9. Щелкните Сохранить.

Можно открыть существующие файлы MapSource, содержащие маршрутные точки, и сохранить их в формате .gpx.


Создание файлов .CSV

Программа POI Loader поддерживает файлы .csv, содержащие долготу, широту, пороги оповещения о скорости и дополнительные комментарии. Для создания файлов .csv можно использовать текстовый редактор, программу MS Excel или аналогичную.

POI Loader использует в файле .csv следующий формат для каждого объекта (скобки [ ] обозначают необязательный текст):

<Долгота>,<Широта>,["]<Имя>[@<Порог оповещения о скорости >]["],["] [комментарий]["]

Долгота и широта должны быть представлены в десятичном градусном формате WGS84 (ггг.ггггг; отрицательные числа обозначают запад и юг).

При заключении имени или комментария в кавычки можно включить в него разрывы строки.

Ниже приведены примеры правильного оформления формата пользовательского объекта:

-94.81549,38.80390,Bonita

-94.79731,38.81099,Ridgeview@25

-94.74240,38.81952,Heritage Park,Отличное место для пикника

-94.76416,38.81227,Garmin,"1200 E. 151st Street

Olathe,KS 66062
913/397.8300"

Информация о скорости может содержаться в имени файла или имени отдельного объекта. Дополнительные сведения см. в разделах Пороги оповещения о скорости и о сближении и Создание файлов пользовательских объектов.


Загрузка настраиваемых растровых изображений

В файлы пользовательских объектов, создаваемые с помощью программы MapSource, можно включить изображения.

Программа POI Loader также может связывать растровые изображения (.bmp) с точками в файле данных, если файл .bmp имеет такое же имя, что и файл данных. Например, растровое изображение "Speed_30.bmp" будет связано со всеми точками в файле "Speed_30.csv" или "Speed_30.gpx". Растровые изображения должны быть сохранены в той же папке, что и файлы данных.

Также можно связывать файлы изображений .bmp со всеми файлами данных в подкатегории. Например, файл изображения "restaurants.bmp" будет связан со всеми точками в подкатегории "Restaurants". Изображения, связанные с отдельными файлами, имеют приоритет над изображениями, связанными с подкатегориями.

Устройство GPS Garmin может иметь определенные требования к размеру изображений. Большинство совместимых устройств Garmin поддерживают значки размером 24x24 пиксела или меньше. Изображения, которые не соответствуют этим требованиям, могут отображаться искаженными на экране устройства.


Дополнительные функции

Программа POI Loader имеет несколько дополнительных функций, включая работу в беззвучном режиме, добавление адреса и контактной информации в пользовательские объекты, а также создание файлов TourGuide. Для использования этих функций требуются специальные навыки и технические знания. Эти функции предназначены для опытных пользователей. Компания Garmin не несет ответственности за повреждение файлов или потерю информации при неправильном использовании функций.

Дополнительную информацию см. в следующих разделах.

Запуск POI Loader в беззвучном режиме

Добавление адреса и контактной информации

Создание файлов TourGuide


Запуск POI Loader в беззвучном режиме

Программу POI Loader можно запустить в беззвучном режиме, что означает, что POI Loader запускается с использованием тех же параметров, что использовались в последний раз. Если какие-либо из этих параметров недоступны, запускается мастер POI Loader, который позволяет настроить эти параметры и продолжить установку пользовательских объектов.

Для запуска в беззвучном режиме запустите POI Loader с помощью командной строки с включенным параметром беззвучного режима, например,

> PoiLoader.exe /silent

ПРИМЕЧАНИЕ. В настоящее время беззвучный режим не поддерживается устройствами Windows Mobile, Pocket PC или Palm.


Добавление адреса и контактной информации

ПРИМЕЧАНИЕ. Эту процедуру рекомендуется выполнять только опытным пользователям. При изменении файлов .gpx вы соглашаетесь с тем, что файлы могут быть повреждены или стать непригодными к использованию в случае неправильного обращения.

Для редактирования файлов .gpx можно использовать текстовый редактор. С помощью текстового редактора можно указать адрес, номер телефона, номер факса, а также адрес эл. почты.

Описание адреса в XML

Порядок указания адреса позволяет указать адреса улиц (до 2-х), город, область, страну и индекс. Эта информация должна вводиться в указанном порядке, однако, некоторые поля можно оставить пустыми. Например, можно указать улицу, область и почтовый индекс, но не указывать второй адрес, город и страну.

Описание контактной информации в XML

Порядок указания контактной информации позволяет указать телефонные номера (до 2-х), номер факса и адрес эл. почты. Эту информацию можно вводить в любом порядке, так как атрибут "Категория" используется для определения типа указываемой информации. Например.

<gpxx:PhoneNumber Category=”Fax”>985-6645</gpxx:PhoneNumber>

Если категория не указана или не поддерживается программой POI Loader, то информация указывается в категории "Телефон" по умолчанию. Например:

<gpxx:PhoneNumber>611-1635</gpxx:PhoneNumber>

Это правильный порядок записи. Поддерживаемое устройство Garmin GPS поместит эти данные, если они доступны, в поле "Телефон".

Следующие данные XML демонстрируют объект, который содержит адрес и контактную информацию. В этом примере адрес указан зеленым цветом, а контактная информация — синим.

<wpt lat="33.335668" lon="-111.950193">

<time>2006-07-10T15:30:29Z</time>

<name>Дом Васи</name>

<extensions>

      <gpxx:WaypointExtension

         …

        <gpxx:DisplayMode>SymbolAndName</gpxx:DisplayMode>

        <gpxx:Categories>

          <gpxx:Category>Категория 1</gpxx:Category>

        <gpxx:Categories>

        <gpxx:Address>

          <gpxx:StreetAddress>Садовая 123</gpxx:StreetAddress>

          <gpxx:StreetAddress>Кв. 321</gpxx:StreetAddress>

          <gpxx:City>Тверь</gpxx:City>

          <gpxx:State>Тверская обл.</gpxx:State>

          <gpxx:Country>Россия</gpxx:Country>

          <gpxx:PostalCode>170016</gpxx:PostalCode>

        <gpxx:Address>

        <gpxx:PhoneNumber Category="Phone">43-78-42</gpxx:PhoneNumber>

        <gpxx:PhoneNumber Category="Fax">44-56-78</gpxx:PhoneNumber>

        <gpxx:PhoneNumber Category="Email">

          tver@testserver.ru

        </gpxx:PhoneNumber>

      <gpxx:WaypointExtension

    <extensions>

  </wpt>

ПРИМЕЧАНИЕ. Этот код XML необходимо вводить в файлы объекта GPX так, как указано выше. В противном случае можно повредить файлы объекта и сделать их непригодными к использованию.


Создание файлов TourGuide

TourGuide – это функция, доступная на совместимых устройствах Garmin. Файлы TourGuide включают в себя пользовательские объекты, содержащие аудиофайлы .mp3 с описанием. При приближении к точке TourGuide начинается воспроизведение файла .mp3, который информирует о точке аналогично экскурсионному туру. Файлы TourGuide должны быть сохранены в формате .gpx.

ПРИМЕЧАНИЕ. Файлы TourGuide обычно создаются сторонними разработчиками.

Для создания точек TourGuide следуйте инструкциям в разделе Создание пользовательских объектов в MapSource и используйте поле Файл/URL, чтобы присоединить необходимые файлы .mp3 к точкам. Для активации функции TourGuide имена файлов .mp3 должны содержать слово "TourGuide". Например, "TourGuide.mp3", "TourGuide USA.mp3" или "TourGuide 12.mp3" – допустимые имена файлов TourGuide.

После создания всех точек TourGuide сохраните их в файле .gpx. Дополнительную информацию см. в разделе Создание пользовательских объектов в MapSource.

После сохранения всех точек TourGuide в файле .gpx можно сохранить их на карту памяти или загрузить на совместимое устройство GPS. Для этого используйте быстрый режим или ручной режим.

Добавление изображений к точкам TourGuide

Можно добавлять изображения .jpg к точкам TourGuide с помощью инструкций по созданию в разделе Создание пользовательских объектов в MapSource. Сохраните изображения .jpg и файлы .mp3 TourGuide в папке, а затем используйте поле Файл/URL, чтобы перейти в эту папку.

Также можно указать путь к изображению .jpg в данных ID3 файла .mp3 TourGuide. Подробные сведения о метках ID3 для файлов .mp3 см. в Интернете.


Удаление пользовательских объектов с устройства

С устройства можно удалить все пользовательские объекты ПРИМЕЧАНИЕ. Для предотвращения потери данных убедитесь, что перед выполнением этой процедуры пользовательские объекты сохранены на компьютере.

Удаление пользовательских объектов с устройства.

  1. Включите устройство GPS Garmin и подключите его к компьютеру. При использовании устройства чтения карт памяти подключите его к ПК.

  2. Запустите POI Loader и щелкните Далее.

  3. Убедитесь, что в поле Устройства отображается соответствующее устройство. В противном случае щелкните Найти устройство. Если к компьютеру подключено несколько устройств, выберите необходимое устройство из раскрывающегося списка.

  4. Щелкните Далее.

  5. Выберите Удалить все ранее установленные настраиваемые объекты c устройства и щелкните Далее.

  6. Щелкните Да. Все пользовательские объекты будут удалены с устройства.